Author Topic: Crafting system bug in 1.5!  (Read 5444 times)

Offline Winter

  • I am Tek Jansen!
  • Administrator
  • *****
  • Posts: 476
  • MBX Forum owner
    • View Profile
    • Street of Eyes: The Writing of Ryan A. Span
Crafting system bug in 1.5!
« on: April 12, 2007, 04:20:06 AM »
Once again bugs have crept in due to wrong material values. I've finally had it with the way Craftmod handles these things, so I've now coded a little script to calculate these values dynamically, saving myself and all future Craftmod users a lot of headache.

The updated 1.5.1 source will be up on the Repository soon. Everyone playing 1.5 or using it for modding is recommended to grab this new source and compile it to fix their Craftmod installs.

royfang

  • Guest
Re: Crafting system bug in 1.5!
« Reply #1 on: April 12, 2007, 11:39:29 PM »
How do I use it to fix my Craftmod install?
« Last Edit: April 13, 2007, 10:42:04 AM by royfang »

Apollon-04

  • Guest
Re: Crafting system bug in 1.5!
« Reply #2 on: April 13, 2007, 08:01:44 AM »

 1.5.1

1.5.1? is that even a number? shouldnt it be 1.51?

MastaSpoofa

  • Guest
Re: Crafting system bug in 1.5!
« Reply #3 on: June 09, 2007, 01:00:25 PM »
How do i use 1.5.1 to update my 1.5 game?

Nibbles

  • Guest
Re: Crafting system bug in 1.5!
« Reply #4 on: June 20, 2007, 07:34:26 PM »
To install:

Download the Python scripting language software to compile it:

http://www.python.org/download/

Install Python.

Extract the folder that contains the version of craftmod you want, i.e. no retainers, no imod, whatever.

Go into that folder.

Right click on Build_Module.bat. Edit. Change the  PATH to wherever you installed Python. Save and close.

Right click on module_info.py in that folder and select "Edit with IDLE." Change the output directory to your Craftmod folder, or into a different folder, e.g. C:\Documents and Settings\USERNAME\Desktop\Craftmod.

[Changing the paths is important, because Winter installed everything to his D directory, so it automatically looks for D:\Python25 and D:\MountandBlade\etc. and I have no D directory so it says access denied when it ran.]

Keep in mind that the folder you output to must exist, so make a folder if there isn't one already.



Figured this one out all on my own in five minutes by googling Python script after I ran the batch.
« Last Edit: June 20, 2007, 07:36:22 PM by Nibbles »

ShadowofDeath92

  • Guest
Re: Crafting system bug in 1.5!
« Reply #5 on: July 01, 2007, 06:24:03 AM »
To install:

Download the Python scripting language software to compile it:

http://www.python.org/download/

Install Python.

Extract the folder that contains the version of craftmod you want, i.e. no retainers, no imod, whatever.

Go into that folder.

Right click on Build_Module.bat. Edit. Change the  PATH to wherever you installed Python. Save and close.

Right click on module_info.py in that folder and select "Edit with IDLE." Change the output directory to your Craftmod folder, or into a different folder, e.g. C:\Documents and Settings\USERNAME\Desktop\Craftmod.

[Changing the paths is important, because Winter installed everything to his D directory, so it automatically looks for D:\Python25 and D:\MountandBlade\etc. and I have no D directory so it says access denied when it ran.]

Keep in mind that the folder you output to must exist, so make a folder if there isn't one already.



Figured this one out all on my own in five minutes by googling Python script after I ran the batch.



Sorry I don't understand the bold part but I really want to play this can you link me to somewhere that says how to do it please?



[EDIT] Nevermind I think i got it :)
« Last Edit: July 01, 2007, 06:46:09 AM by ShadowofDeath92 »

Falterfire

  • Guest
Re: Crafting system bug in 1.5!
« Reply #6 on: September 03, 2007, 07:23:22 PM »

Edit: I think I got it. Is there a simple test I can do to make sure it really updated?

« Last Edit: September 03, 2007, 07:47:45 PM by Falterfire »