Author Topic: TLD 3.3 - Bug Reports  (Read 109627 times)

Offline Swyter

  • Administrator
  • *****
  • Posts: 413
  • �Star Wars Conquest Dev Team Coordinator
    • View Profile
    • [my tiny homepage]
Re: TLD 3.3 - Bug Reports
« Reply #15 on: February 17, 2014, 03:32:34 PM »
Organized your feedback in Trello cards. Take them a look and comment if you can narrow it down.
In two days we've gotten a lot of feedback, this is great. There are very few problems we haven't noticed.
My Mount&Blade Tools: � Iron Launcher for Warband � Iron Launcher � Font Customiser � WarKit

Offline Shazjgeorge

  • Apprentice
  • *
  • Posts: 4
    • View Profile
Re: TLD 3.3 - Bug Reports
« Reply #16 on: February 17, 2014, 07:02:09 PM »
I have 2 points.
First, I found the ford on the river is too narrow, mostly only one army can cross. So sometimes, different armies come from both sides of the ford and trap in the ford, nobody can move unless one army retreat. Such things also happen in the previous version.
And second, this is in the warband version. I still didn't find the reason. I chose Lothlorien and we attack Moria with Rivendell. Just after several days that Moria was defeated, which is the 58th day, the game crashed. I have the save data just less than a day before the game crash. I tried many times, no matter what I did, camp, stay in the city or attack an army, the game will always crash at the same time.

Offline LCJr

  • Journeyman
  • ***
  • Posts: 219
    • View Profile
Re: TLD 3.3 - Bug Reports
« Reply #17 on: February 18, 2014, 03:55:36 PM »
@Swyter  Is the new Iron Launcher supposed to work with Linux?  Manjaro 64-bit, WINE 1.6.2 Stable and M&B 1.011.  No biggie if not just curious.

Offline thecalaquendi

  • Craftsman
  • **
  • Posts: 66
    • View Profile
Re: TLD 3.3 - Bug Reports
« Reply #18 on: February 19, 2014, 01:04:55 AM »
Concerning the crashes caused by wargs, I think I found the problem as well as a possible solution.

After doing some testing I think the crashes are caused by the "armoured wargs" variants.  I have no idea how to fix them, but I used "HokieBT" 's Unofficial Troop Editor and changed all the troops that had armoured wargs to normal wargs and my game is now no longer crashing.

Hope this information helps!

Offline thecalaquendi

  • Craftsman
  • **
  • Posts: 66
    • View Profile
Re: TLD 3.3 - Bug Reports
« Reply #19 on: February 19, 2014, 08:33:02 PM »
And second, this is in the warband version. I still didn't find the reason. I chose Lothlorien and we attack Moria with Rivendell. Just after several days that Moria was defeated, which is the 58th day, the game crashed. I have the save data just less than a day before the game crash. I tried many times, no matter what I did, camp, stay in the city or attack an army, the game will always crash at the same time.

Similar situation happening with me.  My game is crashing on day 31, shortly after a major battle against Moria and Dul Guldur.  Playing as Rivendell.


Here's an update:

OK I found why the game was crashing on a specific day.  The dunlending camp is up in the mountains and because of that, when the dunlanding parties spawn they automatically get stuck.  I guess the solution would be to either move the Dunlending Camp or smooth out the terrain around it.


Here's a second update:

So I've delved further into the issue and I discovered something really odd.  The "Dunlander Camp" changed positions sometime during the beginning of the game and the crash.  At first it was located in the plains south of Isengard and then (before the crash) it is located in the mountains south-west of Isengard.

What might explain that??


And a third update:

Ok so after more testing I've realized that the Dunlender Camp's location changes when the "war" begins, that is to say immediately after the cutsene.  I have NO IDEA how to fix that.
« Last Edit: February 19, 2014, 09:34:32 PM by thecalaquendi »

Offline Shazjgeorge

  • Apprentice
  • *
  • Posts: 4
    • View Profile
Re: TLD 3.3 - Bug Reports
« Reply #20 on: February 19, 2014, 11:28:55 PM »
And second, this is in the warband version. I still didn't find the reason. I chose Lothlorien and we attack Moria with Rivendell. Just after several days that Moria was defeated, which is the 58th day, the game crashed. I have the save data just less than a day before the game crash. I tried many times, no matter what I did, camp, stay in the city or attack an army, the game will always crash at the same time.

Similar situation happening with me.  My game is crashing on day 31, shortly after a major battle against Moria and Dul Guldur.  Playing as Rivendell.


Here's an update:

OK I found why the game was crashing on a specific day.  The dunlending camp is up in the mountains and because of that, when the dunlanding parties spawn they automatically get stuck.  I guess the solution would be to either move the Dunlending Camp or smooth out the terrain around it.


Here's a second update:

So I've delved further into the issue and I discovered something really odd.  The "Dunlander Camp" changed positions sometime during the beginning of the game and the crash.  At first it was located in the plains south of Isengard and then (before the crash) it is located in the mountains south-west of Isengard.

What might explain that??


And a third update:

Ok so after more testing I've realized that the Dunlender Camp's location changes when the "war" begins, that is to say immediately after the cutsene.  I have NO IDEA how to fix that.

Yeah, I see it. There are many armies trapping there and I tried to engage them but even by using Ctrl + mouse1 to move, I still cannot reach them..........

Offline Merlkir

  • Administrator
  • *****
  • Posts: 5742
    • View Profile
    • My DeviantArt online Gallery
Re: TLD 3.3 - Bug Reports
« Reply #21 on: February 20, 2014, 12:39:32 AM »
Obviously, the Dunlander camp shouldn't move, not even when the war starts, so that is indeed a bug.
Here's my gallery: http://merlkir.deviantart.com/

I'm now painting and drawing commissions. I'll paint portraits, pets, girlfriends, favourite characters..you name it. Send me a PM if interested ;)

Offline Swyter

  • Administrator
  • *****
  • Posts: 413
  • �Star Wars Conquest Dev Team Coordinator
    • View Profile
    • [my tiny homepage]
Re: TLD 3.3 - Bug Reports
« Reply #22 on: February 20, 2014, 09:51:13 AM »
@Swyter  Is the new Iron Launcher supposed to work with Linux?  Manjaro 64-bit, WINE 1.6.2 Stable and M&B 1.011.  No biggie if not just curious.

It should work fine, even with the IAT hooks, probably better than the old one as it doesn't requires extra permissions, or even moving files around, it all happens in memory, intercepting and redirecting logic. I know that the Warband framerate in Linux (in my case Arch) is not that great (apart from the nasty out of memory message boxes).

But M&B 1.011 should be okay. Yes.
My Mount&Blade Tools: � Iron Launcher for Warband � Iron Launcher � Font Customiser � WarKit

Offline thecalaquendi

  • Craftsman
  • **
  • Posts: 66
    • View Profile
Re: TLD 3.3 - Bug Reports
« Reply #23 on: February 20, 2014, 01:13:58 PM »
@Swyter  Is the new Iron Launcher supposed to work with Linux?  Manjaro 64-bit, WINE 1.6.2 Stable and M&B 1.011.  No biggie if not just curious.

It should work fine, even with the IAT hooks, probably better than the old one as it doesn't requires extra permissions, or even moving files around, it all happens in memory, intercepting and redirecting logic. I know that the Warband framerate in Linux (in my case Arch) is not that great (apart from the nasty out of memory message boxes).

But M&B 1.011 should be okay. Yes.


Can you add this one to Trello?

Offline Swyter

  • Administrator
  • *****
  • Posts: 413
  • �Star Wars Conquest Dev Team Coordinator
    • View Profile
    • [my tiny homepage]
Re: TLD 3.3 - Bug Reports
« Reply #24 on: February 20, 2014, 01:35:24 PM »
@Swyter  Is the new Iron Launcher supposed to work with Linux?  Manjaro 64-bit, WINE 1.6.2 Stable and M&B 1.011.  No biggie if not just curious.

It should work fine, even with the IAT hooks, probably better than the old one as it doesn't requires extra permissions, or even moving files around, it all happens in memory, intercepting and redirecting logic. I know that the Warband framerate in Linux (in my case Arch) is not that great (apart from the nasty out of memory message boxes).

But M&B 1.011 should be okay. Yes.


Can you add this one to Trello?

The teleporting Dunlander camp in Warband? I've already fixed it. Here, have a card.
https://trello.com/c/edlpaNGx/43-fix-teleporting-dunlander-camp-when-the-war-starts-it-goes-to-the-mountains

By the way, it was meant to be teleported, in fact the camp moves to the other side of the Isen river when the war starts in 1.011, I've confirmed it and... now it's fixed.
« Last Edit: February 20, 2014, 01:37:58 PM by Swyter »
My Mount&Blade Tools: � Iron Launcher for Warband � Iron Launcher � Font Customiser � WarKit

Offline Shazjgeorge

  • Apprentice
  • *
  • Posts: 4
    • View Profile
Re: TLD 3.3 - Bug Reports
« Reply #25 on: February 20, 2014, 03:10:09 PM »
@Swyter  Is the new Iron Launcher supposed to work with Linux?  Manjaro 64-bit, WINE 1.6.2 Stable and M&B 1.011.  No biggie if not just curious.

It should work fine, even with the IAT hooks, probably better than the old one as it doesn't requires extra permissions, or even moving files around, it all happens in memory, intercepting and redirecting logic. I know that the Warband framerate in Linux (in my case Arch) is not that great (apart from the nasty out of memory message boxes).

But M&B 1.011 should be okay. Yes.


Can you add this one to Trello?

The teleporting Dunlander camp in Warband? I've already fixed it. Here, have a card.
https://trello.com/c/edlpaNGx/43-fix-teleporting-dunlander-camp-when-the-war-starts-it-goes-to-the-mountains

By the way, it was meant to be teleported, in fact the camp moves to the other side of the Isen river when the war starts in 1.011, I've confirmed it and... now it's fixed.

Is there any fix patch for this can be released now? Like the fix patch of armored wargs.

Offline Swyter

  • Administrator
  • *****
  • Posts: 413
  • �Star Wars Conquest Dev Team Coordinator
    • View Profile
    • [my tiny homepage]
Re: TLD 3.3 - Bug Reports
« Reply #26 on: February 20, 2014, 03:14:47 PM »
The teleporting Dunlander camp in Warband? I've already fixed it. Here, have a card.
https://trello.com/c/edlpaNGx/43-fix-teleporting-dunlander-camp-when-the-war-starts-it-goes-to-the-mountains

By the way, it was meant to be teleported, in fact the camp moves to the other side of the Isen river when the war starts in 1.011, I've confirmed it and... now it's fixed.

Is there any fix patch for this can be released now? Like the fix patch of armored wargs.

Just because you asked nicely:
https://trello.com/c/edlpaNGx/43-fix-teleporting-dunlander-camp-when-the-war-starts-it-goes-to-the-mountains
My Mount&Blade Tools: � Iron Launcher for Warband � Iron Launcher � Font Customiser � WarKit

Offline Shazjgeorge

  • Apprentice
  • *
  • Posts: 4
    • View Profile
Re: TLD 3.3 - Bug Reports
« Reply #27 on: February 20, 2014, 04:20:06 PM »
The teleporting Dunlander camp in Warband? I've already fixed it. Here, have a card.
https://trello.com/c/edlpaNGx/43-fix-teleporting-dunlander-camp-when-the-war-starts-it-goes-to-the-mountains

By the way, it was meant to be teleported, in fact the camp moves to the other side of the Isen river when the war starts in 1.011, I've confirmed it and... now it's fixed.

Is there any fix patch for this can be released now? Like the fix patch of armored wargs.

Just because you asked nicely:
https://trello.com/c/edlpaNGx/43-fix-teleporting-dunlander-camp-when-the-war-starts-it-goes-to-the-mountains

Thanks a lot :P

Offline thecalaquendi

  • Craftsman
  • **
  • Posts: 66
    • View Profile
Re: TLD 3.3 - Bug Reports
« Reply #28 on: February 20, 2014, 05:45:35 PM »
Great job Swyter.  It's great to see this mod revived after so many years!

Offline LCJr

  • Journeyman
  • ***
  • Posts: 219
    • View Profile
Re: TLD 3.3 - Bug Reports
« Reply #29 on: February 20, 2014, 08:36:36 PM »
@Swyter  Is the new Iron Launcher supposed to work with Linux?  Manjaro 64-bit, WINE 1.6.2 Stable and M&B 1.011.  No biggie if not just curious.

It should work fine, even with the IAT hooks, probably better than the old one as it doesn't requires extra permissions, or even moving files around, it all happens in memory, intercepting and redirecting logic. I know that the Warband framerate in Linux (in my case Arch) is not that great (apart from the nasty out of memory message boxes).

But M&B 1.011 should be okay. Yes.

Got it working.  In WineConfig > mount&blade.exe > Libraries > d8input.dll needs to be set to (native, builtin).