login

Author Topic: Bug Reports for 0.6.6  (Read 69097 times)

Offline Conners

  • Master
  • *****
  • Posts: 533
    • View Profile
Re: Bug Reports for 0.6.6
« Reply #60 on: January 09, 2010, 06:36:15 am »
There seems to be some sort of an item bug or possibly a unit bug that causes the game to crash when you enter battles. I was going into battle with a group of forest bandits, this being the 6th battle with them or so, and now the game crashes whenever I try to charge the enemy.
The group can be 26 bandits or 49 bandits, haven't tried other enemies (hard to find other enemies). I had about 20 troops at the time. Couldn't be my number of troops as the problem, since I had a battle with 200+ ally troops vs. 36 enemies (few of my own, but still).

The game had been running smoothly up to this point, and I was using Direct X7 rather than X9.I can try and work out which equipment or unit it is tomorrow, if you'd like me to (or if it's some other problem if I can work it out).

Chopa

  • Guest
Re: Bug Reports for 0.6.6
« Reply #61 on: January 09, 2010, 02:12:49 pm »
  Did you recruit any rescued prisoners before the crashes started? I wonder if you are getting the same bug I had?

" 8/ Issue with SOME Village Defenders and Veteran Defenders recruited from prisoners freed from bandits in the wood near Sansa. Sometimes CTD when attacking bandits with Defenders in party. Disband Village Defender, or Veteran Defender and the attack proceeds."

Offline Conners

  • Master
  • *****
  • Posts: 533
    • View Profile
Re: Bug Reports for 0.6.6
« Reply #62 on: January 09, 2010, 06:39:37 pm »
Yes. Thank you for pointing that out (on another odd note, their salary is 100 mon.... that's a lot for an unarmoured female peasant). It went fine when I had only 1 village defender. But I don't think I had any veteran defenders in the battles I waged. I'll test it out and see if it's related to having a veteran defender or not.

Chopa

  • Guest
Re: Bug Reports for 0.6.6
« Reply #63 on: January 09, 2010, 07:23:23 pm »
  Could be EITHER a Veteran Defender OR a Village Defender, I've had it both ways, and only certain ones...some do not trigger the crash on battle start up. No idea why......

Offline Ron Losey

  • Master
  • *****
  • Posts: 4418
    • View Profile
Re: Bug Reports for 0.6.6
« Reply #64 on: January 10, 2010, 12:07:31 am »
Guys, it's a bad item entry of some kind.  That's why it's random.  Only sometimes do the village defenders get whatever the offending item might be.  (We've seen similar bugs before.)

I would look it up, but Fujiwara has all the new code, and it's going to have to get some more debugging before I dare fumble with it anyway.

Offline Conners

  • Master
  • *****
  • Posts: 533
    • View Profile
Re: Bug Reports for 0.6.6
« Reply #65 on: January 13, 2010, 09:41:18 am »
With the Sansa (pitchfork), I think it's just too lightning fast.. not sure if this is just a problem with the engine, but... I thrust at them about 0.2 seconds ahead with a katana -- when I have high skill and agility -- this is after I have just parried them. The ruffian still manages to stab me before my blade touches them...I can kill armies of ruffians, but those pitchfork wielders have become like great demons in human form.

cave sexte

  • Guest
Re: Bug Reports for 0.6.6
« Reply #66 on: January 14, 2010, 12:49:49 pm »
I saw a couple entries on this earlier, but purely for informational purposes, has anyone been able to continue a game past day 40 or so with 0.6.6? Is this an "everybody has it" problem or could it be something I'm doing wrong? I've got a serious ONR jones going on but I don't want to restart a character if I'm inevitably going to have to toss them and start over again in 40 game days.

Offline Conners

  • Master
  • *****
  • Posts: 533
    • View Profile
Re: Bug Reports for 0.6.6
« Reply #67 on: January 15, 2010, 01:30:35 am »
Well, cave sexte, you can Export your character's file (face info, level and stats, money) and import it to your new created character.

cave sexte

  • Guest
Re: Bug Reports for 0.6.6
« Reply #68 on: January 15, 2010, 04:26:00 pm »
Thanks Connors, I'm aware that there are workarounds. I'm just trying to determine what the frequency of the issue is - i.e. is it a problem *everybody* has, or many people, or only a very few. If it's a universal problem, then I won't worry about trying to work around it and just wait for the next version. If not, I want to try some different mitigation strategies.

Offline Conners

  • Master
  • *****
  • Posts: 533
    • View Profile
Re: Bug Reports for 0.6.6
« Reply #69 on: January 16, 2010, 02:13:45 am »
I've had the problem too. So it's probably universal till the next version.

Miura

  • Guest
Re: Bug Reports for 0.6.6
« Reply #70 on: January 29, 2010, 05:32:41 am »
Hi all,

In first, excuse me for my little (and probably wrong sometimes) english ! this is not my mother language ^^

Like Penguinking i have this error when i am supposed to speak with my commander, after the quest of the River Pirates

http://s163.photobucket.com/albums/t291/penguinking100/?action=view&current=mb6.jpg

Its really bad because i cant continue the storyline and the main quest :/
Also, i just can enter in the South Kyoto, its bug ?
Oh, and i cant speak with the Taicho of an army when i try, i'am automaticaly redirected to the landmap.

Thanks for your great mod & your help ! (i hope ^^)

[Johny]

  • Guest
Re: Bug Reports for 0.6.6
« Reply #71 on: February 04, 2010, 07:48:28 am »
regarding bad item crushes - i have some ideas that it could be "Sharpwave" - quest  sword to hire  one of NPC (sorry forget name)
I already have 2 bad saves - game crushes before loading  global map. they occurred right after i complete quest at Aoio smith for preparing this sword.

1st time i  managed to travel till Sanda - even do not pass this sword to NPC.
2nd i pass sword to NPC and travel with him 1 day before game crushed and save lost.

3rd time i do not want to start again... will wait till next patch.

Offline Jamould

  • Apprentice
  • *
  • Posts: 30
    • View Profile
Re: Bug Reports for 0.6.6
« Reply #72 on: March 12, 2010, 06:01:46 pm »
Yeah Im getting the day 40 crash as well Ive noticed if you camp just before the day it crashes when it gets to the day it normallly crashes at it doesnt crash but I notice the game lags alot and as soon as I come out of camping it crashes but maybe if I camp for enough days Ill be able to come out of it without crashing

dingdong

  • Guest
Re: Bug Reports for 0.6.6
« Reply #73 on: March 17, 2010, 06:41:28 am »
http://img63.imageshack.us/img63/7051/bugkr.jpg

Clicking left doesn't do anything.
« Last Edit: March 17, 2010, 02:42:25 pm by dingdong »

ukraineca

  • Guest
Re: Bug Reports for 0.6.6
« Reply #74 on: March 20, 2010, 03:47:51 pm »
It gives me Don't send after i tried to attack the patrol  >:(