login

Author Topic: Bug Reports for 0.6.6  (Read 36552 times)

dulahan

  • Guest
Re: Bug Reports for 0.6.6
« Reply #15 on: December 13, 2009, 12:48:39 AM »
}

technique specular_alpha_cutouts
{
   pass P0
   {
      VertexShader = compile vs_2_0 vs_specular_alpha(PCF_NONE);
      PixelShader = compile ps_2_0 ps_specular_alpha_cutouts(PCF_NONE);
   }
}




-That's exactly what I found with the two versions that have it in mb.fx

penguinking100

  • Guest
Re: Bug Reports for 0.6.6
« Reply #16 on: December 13, 2009, 04:21:34 AM »
i can alt-tab out but when i click on the rgl error box at the bottom of my screen or bring up the task manager and select the rgl error to bring to front their both just plain black screens


also, most if not all or the rgl errors are from entering or exiting places in towns and city's, I've had no errors from battles.

who could a novice modder such as me help out with this mod? I really enjoy this mod but its so unfinished i just want to pitch in and help to progress the development of it =)


correction i keep on getting rgl errors whenever i attack mountain bandits for a temple monk quest idk if it has to do with the quest (since quests are kinda a no no so far in this release) or my army idk


ya its the bandits

also would you like a list of all locations where im getting rgl's since i cant give u the exact rgl error?

i am also running into a bug or something that every time i exit a city or town or whatever, the game gose into super hyper (your resting at the inn) kinda mode and i have to click to move away a couple of times to continue. idk if that was mentioned by some1 somewhere already but whatev just tryin to help  ;)

n just a quick question is every1 getting a lot or RGL errors or is it just me?
« Last Edit: December 13, 2009, 12:18:55 PM by penguinking100 »

dulahan

  • Guest
Re: Bug Reports for 0.6.6
« Reply #17 on: December 13, 2009, 11:23:58 AM »
I think the Town thing you mentioned is just time passing to represent the time you've been in the town.

Offline Bromden

  • Apprentice
  • *
  • Posts: 3
    • View Profile
Re: Bug Reports for 0.6.6
« Reply #18 on: December 13, 2009, 11:36:41 AM »
When I first ran Onin no Ran, the graphics were glitchy, seemed shader problems,
so I switched to dx7, that solved it. I've got a Radeon HD3850,
so the problem seems to be with the dx9 shaders(I'm not pro in this stuff).

another: when I got captured, the camera stays on the same spot on the map,
and jumps to my location when I escape.

Offline fujiwara

  • Moderator
  • *****
  • Posts: 858
    • View Profile
Re: Bug Reports for 0.6.6
« Reply #19 on: December 13, 2009, 12:21:34 PM »
When I first ran Onin no Ran, the graphics were glitchy, seemed shader problems,
so I switched to dx7, that solved it. I've got a Radeon HD3850,
so the problem seems to be with the dx9 shaders(I'm not pro in this stuff).

another: when I got captured, the camera stays on the same spot on the map,
and jumps to my location when I escape.


This may be why I've don't see any of these problems; I don't run in DX9 mode b/c my video card can't handle it (graphics are slow and stutter)

The horses tend to get their legs caught in the catapult rather than being properly launched.

dulahan

  • Guest
Re: Bug Reports for 0.6.6
« Reply #20 on: December 13, 2009, 12:25:13 PM »
I'll give it a try in DX 7 mode and see what happens.


EDIT:  I've only gone through afew menus.  But already been able to go longer than before.  Though the Dojo thing on the Kengo training is still happening (AKA: I do one fight, and then get booted from the second, at which point it ends)  Confirmed it happens in Kyoto now too.
« Last Edit: December 13, 2009, 12:37:23 PM by dulahan »

dulahan

  • Guest
Re: Bug Reports for 0.6.6
« Reply #21 on: December 13, 2009, 02:42:23 PM »
Not precisely a bug.  But very annoying nonetheless.


You really need to have food come in much bigger batches than 5 to 20.  Half my inventory is taken up for only 26 people and I can still barely keep enough in stock.

penguinking100

  • Guest
Re: Bug Reports for 0.6.6
« Reply #22 on: December 13, 2009, 03:35:41 PM »
ok weird thing about fighting the bandits when i cranked down the battle size an boom, i could fight them. i actually kinda like fighting smaller battles in this mod, in a way seems more realistic if memory serves me back in the day japanese battles were more like a big cluster of duels instead of mass of dudes vs mass of dudes it was more this guy vs this guy X 1000 idk correct me if im wrong lol

dulahan

  • Guest
Re: Bug Reports for 0.6.6
« Reply #23 on: December 13, 2009, 03:43:11 PM »
I think it was the Onin War that changed that.  To a point the wars that led to te Kamakura Shogunate did too, especially after the Mongol Invasion.  But definitely the Onin war did too.

Offline Conners

  • Master
  • *****
  • Posts: 533
    • View Profile
Re: Bug Reports for 0.6.6
« Reply #24 on: December 13, 2009, 04:14:47 PM »
(Please note that I'm not greatly familiar with Onin no Ran, and may mistake how something just is as a bug) Just now, I planned to test out a possible morale bug (or just a general problem in the system) where when the enemy routs they won't leave the battlefield and will just sit on the edges. However, unable to find riverpirates, I decided to raid caravans. They told me theri Demand and Supply. which was left blank. The only option allowed was to Leave without one of Attacking. Moving onto some Refugees, the game crashed and exited.

Hope this gives some insight. The game is still very fun despite these bugs, BTW.

Offline Shik

  • Craftsman
  • **
  • Posts: 88
    • View Profile
Re: Bug Reports for 0.6.6
« Reply #25 on: December 13, 2009, 07:35:33 PM »
I'm also getting a crash upon entering the Female character creation screen, like Dulahan.

Some minor bugs:
Leadership bonus doesn't display correctly in the camp party reports menu.
Prisoner Management only gives +5 bonus, while the skill description claims +10.

penguinking100

  • Guest
Re: Bug Reports for 0.6.6
« Reply #26 on: December 13, 2009, 11:49:10 PM »
i changed my configuration from drx9 to drx7 and the rgl errors have essentially stopped IT HELPED A HELL OF A LOT!!!!! :D :D
i can actually play without oni crashing every 5 seconds lol

one thing though i cant figure out how to recruit any other troops than the ones in the inn
and i am also getting this error for the quest of joining a faction and becoming a vassal/retainer/subordinate? of a lord, its only like the second quest for becoming part of a faction.
the error...
http://s163.photobucket.com/albums/t291/penguinking100/?action=view&current=mb6.jpg

also idk if its a bug but i cant enter any kyoto other that south kyoto
« Last Edit: December 14, 2009, 12:21:34 AM by penguinking100 »

Offline Conners

  • Master
  • *****
  • Posts: 533
    • View Profile
Re: Bug Reports for 0.6.6
« Reply #27 on: December 14, 2009, 01:40:27 AM »
Alpha Cut-outs error still appears to exist. I was fighting 34 River Pirates with about 15 guys. The Game crashed mid-battle with the alpha cutouts.

Offline fujiwara

  • Moderator
  • *****
  • Posts: 858
    • View Profile
Re: Bug Reports for 0.6.6
« Reply #28 on: December 14, 2009, 02:46:07 AM »
I have several confirmations from the Taleworlds board that everything works fine under DX7 but is crash and burn under DX9. I can only assume this has something to do with the custom shader. Ron, it seems many new shaders were added for M&B 1.01x. Would any of them be sufficient for what we're trying to achieve with the specular_alpha_cutouts shader?

The horses tend to get their legs caught in the catapult rather than being properly launched.

Offline Bromden

  • Apprentice
  • *
  • Posts: 3
    • View Profile
Re: Bug Reports for 0.6.6
« Reply #29 on: December 14, 2009, 04:26:39 AM »
Every time the game notices me about some Hosokawa scouts,
the camera rushes off on the map to a location that must be the spies',
and starts following them (I think; I can't see them because of distance)
I get my cam back when I click/move/anything.