login

Author Topic: Bug Reports for 0.6.6  (Read 38860 times)

Offline fujiwara

  • Moderator
  • *****
  • Posts: 858
    • View Profile
Bug Reports for 0.6.6
« on: December 09, 2009, 07:45:55 PM »
Post bugs for v0.6.6 here! Thanks for the reports for the last build.

The horses tend to get their legs caught in the catapult rather than being properly launched.

Offline ghanburighan

  • Craftsman
  • **
  • Posts: 57
    • View Profile
Re: Bug Reports for 0.6.6
« Reply #1 on: December 10, 2009, 03:19:51 PM »
So far I've noticed that:
- Iron Flesh and Power Strike cannot be chosen as skills (+ button doesn't work)
- Scouts continue to harass you, if you just say goodbye, they will just keep bumping into you (don't know if this is intentional)
- party name is  ['s party] intstead of [Playername's party]
- in character selection, sometimes hair seems to be missing texture, appearing as pure white
- music still doesn't work, unfortunately (because the music's good)
« Last Edit: December 10, 2009, 03:30:19 PM by ghanburighan »

Offline fujiwara

  • Moderator
  • *****
  • Posts: 858
    • View Profile
Re: Bug Reports for 0.6.6
« Reply #2 on: December 10, 2009, 04:25:49 PM »
So far I've noticed that:
- Iron Flesh and Power Strike cannot be chosen as skills (+ button doesn't work)

Found out this is a bug with M&B 1.011, having to do with some skills being marked with the sf_inactive flag. I've activated one of the reserved skills, and Ironflesh and Power Strike work now, so I'll have to name it something meaningful. Stealth is something we've kicked around for a while, but it seems my hand had been forced.

Quote
- Scouts continue to harass you, if you just say goodbye, they will just keep bumping into you (don't know if this is intentional)

This is new; I'll have to investigate

Quote
- party name is  ['s party] intstead of [Playername's party]

I've seen this too. Not sure why, since the code is the same as Native for this.

Quote
- in character selection, sometimes hair seems to be missing texture, appearing as pure white

Yeah; I disabled the blonde hair texture, and apparently that's the base texture. I have some ideas on this; stay tuned.

Quote
- music still doesn't work, unfortunately (because the music's good)

I haven't had problems with it. Funny.


The horses tend to get their legs caught in the catapult rather than being properly launched.

Offline fujiwara

  • Moderator
  • *****
  • Posts: 858
    • View Profile
Re: Bug Reports for 0.6.6
« Reply #3 on: December 10, 2009, 04:27:20 PM »
Some other good news: thanks to Janus, I've been able to get the custom mb.fx file into the installer and will install correctly in the root M&B folder. That should resolve everyone's specular_alpha_cutouts issues

The horses tend to get their legs caught in the catapult rather than being properly launched.

Offline Shik

  • Craftsman
  • **
  • Posts: 88
    • View Profile
Re: Bug Reports for 0.6.6
« Reply #4 on: December 10, 2009, 05:19:10 PM »
River Pirate parties seem to stop spawning after awhile. I can't finish the quest to become assigned to a Shugo because of that.

Dialog error when discussing debug info with companions:


The recent post that I made in the .6.5 thread was meant to be for .6.6, since there wasn't a thread for .6.6 bugs when I posted.

But yeah, I'm getting the no-music bug as well.
« Last Edit: December 10, 2009, 05:23:29 PM by Shik »

Offline Ron Losey

  • Master
  • *****
  • Posts: 4418
    • View Profile
Re: Bug Reports for 0.6.6
« Reply #5 on: December 10, 2009, 06:31:01 PM »
On the hair texture, use only the Hair_blonde (or whatever it was called) in module_skins.py  ... and let the game reset the colors on its own. 

  (
    "man", 0,
    "man_body", "man_calf_l", "m_handL",
    "male_head", man_face_keys,
    ["man_hair_s","man_hair_m","man_hair_n","man_hair_o", "man_hair_y10", "man_hair_y12","man_hair_p","man_hair_r","man_hair_q","man_hair_v","man_hair_t","man_hair_y6","man_hair_y3","man_hair_y7","man_hair_y9","man_hair_y11","man_hair_u","man_hair_y","man_hair_y2","man_hair_y4"], #man_hair_meshes ,"man_hair_y5","man_hair_y8",
    ["beard_e","beard_d","beard_k","beard_l","beard_i","beard_j","beard_z","beard_m","beard_n","beard_y","beard_p","beard_o",   "beard_v", "beard_f", "beard_b", "beard_c","beard_t","beard_u","beard_r","beard_s","beard_a","beard_h","beard_g",], #beard meshes ,"beard_q"
#    ["hair_blonde", "hair_red", "hair_brunette", "hair_black", "hair_white"], #hair textures
#    ["beard_blonde","beard_red","beard_brunette","beard_black","beard_white"], #beard_materials
   ["hair_blonde"], #hair textures
    ["beard_blonde"], #beard_materials

#

MBhooked

  • Guest
Re: Bug Reports for 0.6.6
« Reply #6 on: December 11, 2009, 05:24:43 PM »
I'm getting the "Unable to get technique with name specular_alpha_cutouts" error every 10 minutes of play or so.  I used 7 zip to peek into the .exe file, and I do not see the MB.FX file in there at all.  So, unlesss it is being compiled somehow, I think that the MB.FX is just accidentally left out.  I tried replacing the current MB.FX in the main folder with the custom MB.FX fuji posted lin 2008, put I'm still getting the errors.  Could you possibly post a link to your new MB.FX so I can pop it in and keep playing/testing this great mod?

Thanks!!
« Last Edit: December 11, 2009, 06:21:22 PM by MBhooked »

penguinking100

  • Guest
Re: Bug Reports for 0.6.6
« Reply #7 on: December 12, 2009, 10:56:33 AM »
i dont know if its a bug or what but are the prices for equipment suppose to be in the 100,000 range for a lot of stuff? idk it just seems they pay u get from stuff is not even close enough to pay for anything...idk
any way great mod (or at least the little bit i was able to see) i keep getting rgl errors about every time i talk with some1 for a bandit killing quest or with the store merchants, and is their a horse merchant i couldnt find um?

ive also been getting some odd screen things happening, like for you inventory screen some objects like swords, their picture will disappear, buttons act and look funny when u click um, idk just odd little things like that.
« Last Edit: December 12, 2009, 11:02:48 AM by penguinking100 »

Offline fujiwara

  • Moderator
  • *****
  • Posts: 858
    • View Profile
Re: Bug Reports for 0.6.6
« Reply #8 on: December 12, 2009, 02:07:37 PM »
Item prices are correct; the reflect the high cost of such items during the time period. A high quality suit of armor was described as being worth "a small village".

There are some UI issue left to iron out.  I still have to figure out the new way these things are done.

Note: For all RGL errors, please, Please, PLEASE write down or copy to clipboard the error text. A RGL error is a generic graphical error; only the message text will actually tell me what's wrong.

The horses tend to get their legs caught in the catapult rather than being properly launched.

TBR

  • Guest
Re: Bug Reports for 0.6.6
« Reply #9 on: December 12, 2009, 02:28:12 PM »
I'm getting the "Unable to get technique with name specular_alpha_cutouts" error every 10 minutes of play or so.  I used 7 zip to peek into the .exe file, and I do not see the MB.FX file in there at all.  So, unlesss it is being compiled somehow, I think that the MB.FX is just accidentally left out.  I tried replacing the current MB.FX in the main folder with the custom MB.FX fuji posted lin 2008, put I'm still getting the errors.  Could you possibly post a link to your new MB.FX so I can pop it in and keep playing/testing this great mod?

Thanks!!

I'm getting "Unable to get technique with name specular_alpha_cutouts" every second or third screen change, even when returning to the game from being "alt-tabbed" out to work with an exported character. When this first occured I did manually install the custom shaders in case the installer didn't. The "Unable to get technique with name specular_alpha_cutouts" error still pops up too often to play though, so I reckon it's not the shaders. Might it be a Vista issue?

penguinking100

  • Guest
Re: Bug Reports for 0.6.6
« Reply #10 on: December 12, 2009, 03:09:16 PM »
i would write down the RGL errors if it would let me see them n not just be a solid black screen of doom, sorry man, vista hates properly reporting errors :(
also, where do you recruit troops?
whenever i go into an inn its just the inn keeper or an npc hero, which i recruited by the way and she just stands their in battle lol, the npc's name is haruko (or something very similar) if that helps or has any relevance to why she just stands their lol.

also is it just me or dose every1 have oni no ran version 161740112.110152321101535211015232 ???
« Last Edit: December 12, 2009, 03:37:32 PM by penguinking100 »

Offline fujiwara

  • Moderator
  • *****
  • Posts: 858
    • View Profile
Re: Bug Reports for 0.6.6
« Reply #11 on: December 12, 2009, 09:14:08 PM »
You can't alt-Tab out? TGF Xp then.

Troops are recruited at inns. YOu may have to grease the innkeeper's palm somehow, though...

The version number i have no idea about.

The horses tend to get their legs caught in the catapult rather than being properly launched.

dulahan

  • Guest
Re: Bug Reports for 0.6.6
« Reply #12 on: December 12, 2009, 10:15:49 PM »
When trying to create a Female Ronin, I get a black screen that then turns into an error report.  About to try other character types...

EDIT: Seems to be an issue with females in general.
« Last Edit: December 12, 2009, 10:24:02 PM by dulahan »

dulahan

  • Guest
Re: Bug Reports for 0.6.6
« Reply #13 on: December 12, 2009, 10:26:32 PM »

And I'm getting the Spectacular Alpha Cutouts thing a lot now too.

EDIT:  The dojos are especially bad.  I can do a fight, at best.  Then it crashes when I talk to the sensei again.


EDIT 2:  OK, decided to try Kengo training in Yodo, and the first one was normal.  Then started the second fight, and immediately it poofed me back to the dojo.  I went to talk to the sensei again... and it said Quest Completed Quest Cancelled.  And gave me all the rewards for finishing it.
« Last Edit: December 12, 2009, 11:42:13 PM by dulahan »

Offline fujiwara

  • Moderator
  • *****
  • Posts: 858
    • View Profile
Re: Bug Reports for 0.6.6
« Reply #14 on: December 13, 2009, 12:30:48 AM »

And I'm getting the Spectacular Alpha Cutouts thing a lot now too.

EDIT:  The dojos are especially bad.  I can do a fight, at best.  Then it crashes when I talk to the sensei again.


EDIT 2:  OK, decided to try Kengo training in Yodo, and the first one was normal.  Then started the second fight, and immediately it poofed me back to the dojo.  I went to talk to the sensei again... and it said Quest Completed Quest Cancelled.  And gave me all the rewards for finishing it.

Please do me a favor. Open mb.fx in a text editor and scroll to the bottom. Confirm for me that there is a definition for specular_alpha_cutouts. IF there is, we need to get mtarini's opinion on this, since he was the author of the custom shaders. Thanks.

The horses tend to get their legs caught in the catapult rather than being properly launched.