MBX

Mount&Blade Expansion => Mod Graveyard => Holy War Mod => Topic started by: marcigaglio on May 14, 2009, 02:39:50 pm

Title: excuse me...
Post by: marcigaglio on May 14, 2009, 02:39:50 pm
but, where I can download this mod???? and what version of MeB have I should already installed? ...thanks
Title: Re: excuse me...
Post by: Mdgrim on May 21, 2009, 06:13:38 am
but, where I can download this mod???? and what version of MeB have I should already installed? ...thanks

its not out.... He has supposingly been working it since like 2006 or something like that